CVE-2019-11043

From Exploited flaws, HARD’s guide to the flaws being used in attacks · Checked
This article is about a flaw in PHP FastCGI Process Manager (FPM). For every flaw being used in attacks, see Exploited flaws; for PHP’s, see PHP flaws being used in attacks.

CVE-2019-11043 is a security flaw in PHP FastCGI Process Manager (FPM), the programming language behind many websites. Attackers can run their own code on PHP FastCGI Process Manager (FPM). The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 25 Mar 2022, and says ransomware gangs have used it.[1]

PHP FastCGI Process Manager (FPM) is business software or equipment. Most families won’t have it, but attackers break into it to get inside companies, and from there to what those companies hold about their customers, patients and staff. Fixed in version 7.1.33, 7.2.24 and 7.3.11 of PHP.

Description

CISA calls it a buffer overflow in PHP FastCGI Process Manager (FPM). In its words: “In some versions of PHP in certain configurations of FPM setup, it is possible to cause FPM module to write past allocated buffers allowing the possibility of remote code execution.”[1]

The CVE record adds: “In PHP versions 7.1.x below 7.1.33, 7.2.x below 7.2.24 and 7.3.x below 7.3.11 in certain configurations of FPM setup it is possible to cause FPM module to write past allocated buffers into the space reserved for FCGI protocol data, thus opening the possibility of remote code execution.”[2]

The underlying weakness is buffer overflow (CWE-120), in MITRE’s list of common software weaknesses.

It scores 9.8 out of 10 on the Common Vulnerability Scoring System, which rates it critical, scored by NVD using CVSS 3.1.[2]

Affected versions

NVD’s record lists these fixed versions: in each line, everything before the version shown is affected.[2]

ProductFixed in
PHP7.1.33
PHP7.2.24
PHP7.3.11

Most families won’t have PHP FastCGI Process Manager (FPM); it’s for whoever looks after IT at work.

Exploitation

CISA added it to its catalog of known exploited vulnerabilities on 25 Mar 2022, 879 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 15 Apr 2022 to fix it.[1] CISA says ransomware gangs have used it.

FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at over 99%. That’s in the top 1% of the flaws it scores.[3]

CISA assesses it as not automatable: each attack takes some work.

CISA doesn’t say who was attacked, or how.

Fix

CISA’s required action: “Apply updates per vendor instructions.”[1]

  1. Check whether you use it.PHP FastCGI Process Manager (FPM) is business software or equipment, so most families won’t have it. If you run a business, or work from home on company equipment, ask whoever looks after your IT.
  2. Send this page to your IT person.Ask them to confirm it’s fixed (fixed in version 7.1.33, 7.2.24 and 7.3.11 of PHP), or not in use. CISA gave US government agencies until 15 Apr 2022 to fix it.
  3. If it can’t be fixed, take it offline.CISA’s advice when there’s no fix is to stop using the product, or take it off the internet, until there is one.

You can’t fix someone else’s server, but you can watch for what follows a break-in like this: a breach notice, a password reset you didn’t ask for, or a scam message that knows things it shouldn’t. HARD watches for those for you and your family.

Timeline

DateEvent
The flaw is made public in the National Vulnerability Database, with a severity score of 9.8.[2]
CISA adds it to its catalog of flaws known to be used in attacks, noting that ransomware gangs have used it.[1]
CISA’s deadline for US government agencies to fix it.[1]
FIRST puts the odds of it being used in attacks in the next 30 days at over 99%.[3]

See also

Other PHP flaws

Other buffer overflow flaws

  • CVE-2025-43520, Apple devices: classic buffer overflow ·
  • CVE-2022-37055, D-Link Routers: buffer overflow ·
  • CVE-2025-20333, Cisco Secure Firewall Adaptive Security Appliance and Secure Firewall Threat Defense: secure firewall adaptive security appliance (ASA) and secure firewall threat defense (FTD) buffer overflow ·
  • CVE-2020-15069, Sophos XG Firewall: buffer overflow ·
  • CVE-2023-41064, Apple iOS, iPadOS, and macOS: imageIO buffer overflow ·

Added the same day

  • CVE-2022-26318, WatchGuard Firebox and XTM Appliances: arbitrary code execution ·
  • CVE-2022-26143, Mitel MiCollab, MiVoice Business Express: access control ·
  • CVE-2022-21999, Microsoft Windows: print spooler privilege escalation ·
  • CVE-2021-42237, Sitecore XP: remote command execution ·
  • CVE-2021-22941, Citrix ShareFile: improper access control ·

Every PHP flaw on CISA’s list · Everything added in March 2022

References

  1. ^ Cybersecurity and Infrastructure Security Agency. “PHP FastCGI Process Manager (FPM) Buffer Overflow Vulnerability”. Known Exploited Vulnerabilities Catalog, added 25 Mar 2022.
  2. ^ National Institute of Standards and Technology. “CVE-2019-11043 Detail”. National Vulnerability Database, published 28 Oct 2019.
  3. ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.998, percentile 100.0, 31 Oct 2026.
  4. CVE Program. “CVE-2019-11043”. The official CVE record.

This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.