CVE-2020-11023

From Exploited flaws, HARD’s guide to the flaws being used in attacks · Checked
This article is about a flaw in JQuery. For every flaw being used in attacks, see Exploited flaws.

CVE-2020-11023 is a security flaw in JQuery. Attackers can run code in the browser of someone using JQuery and act as them. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 23 Jan 2025.[1]

JQuery is business software or equipment. Most families won’t have it, but attackers break into it to get inside companies, and from there to what those companies hold about their customers, patients and staff. JQuery has published a fix or advice.

Description

CISA calls it a cross-site scripting (XSS) in JQuery JQuery. In its words: “JQuery contains a persistent cross-site scripting (XSS) vulnerability. When passing maliciously formed, untrusted input enclosed in HTML tags, JQuery's DOM manipulators can execute untrusted code in the context of the user's browser.”[1]

The CVE record adds: “In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.”[2]

The underlying weakness is cross-site scripting (CWE-79), in MITRE’s list of common software weaknesses.

It scores 6.1 out of 10 on the Common Vulnerability Scoring System, which rates it medium, scored by NVD using CVSS 3.1.[2]

Affected versions

NVD’s record doesn’t list version ranges for it; JQuery’s advisory has them[3]. CISA names the product as JQuery JQuery.

Most families won’t have JQuery; it’s for whoever looks after IT at work.

Exploitation

CISA added it to its catalog of known exploited vulnerabilities on 23 Jan 2025, 1,730 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 13 Feb 2025 to fix it.[1]

FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 85%. That’s in the top 1% of the flaws it scores.[4]

CISA assesses it as not automatable: each attack takes some work.

CISA doesn’t say who was attacked, or how.

Fix

JQuery has published a fix or advice.[3] CISA’s required action: “Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.”[1]

  1. Check whether you use it.JQuery is business software or equipment, so most families won’t have it. If you run a business, or work from home on company equipment, ask whoever looks after your IT.
  2. Send this page to your IT person.Ask them to confirm it’s fixed, or not in use. CISA gave US government agencies until 13 Feb 2025 to fix it.
  3. If it can’t be fixed, take it offline.CISA’s advice when there’s no fix is to stop using the product, or take it off the internet, until there is one.

You can’t fix someone else’s server, but you can watch for what follows a break-in like this: a breach notice, a password reset you didn’t ask for, or a scam message that knows things it shouldn’t. HARD watches for those for you and your family.

Timeline

DateEvent
The flaw is made public in the National Vulnerability Database, with a severity score of 6.1.[2]
CISA adds it to its catalog of flaws known to be used in attacks.[1]
CISA’s deadline for US government agencies to fix it.[1]
FIRST puts the odds of it being used in attacks in the next 30 days at 85%.[4]

See also

Other cross-site scripting flaws

  • CVE-2026-42897, Microsoft: exchange server cross-site scripting ·
  • CVE-2025-48700, Synacor Zimbra Collaboration Suite (ZCS): cross-site scripting ·
  • CVE-2025-66376, Synacor Zimbra Collaboration Suite (ZCS): cross-site scripting ·
  • CVE-2025-68461, Roundcube Webmail: cross-site scripting ·
  • CVE-2021-26829, OpenPLC ScadaBR: cross-site scripting ·

References

  1. ^ Cybersecurity and Infrastructure Security Agency. “JQuery Cross-Site Scripting (XSS) Vulnerability”. Known Exploited Vulnerabilities Catalog, added 23 Jan 2025.
  2. ^ National Institute of Standards and Technology. “CVE-2020-11023 Detail”. National Vulnerability Database, published 29 Apr 2020.
  3. ^ JQuery. Advisories and fixes: github.com, blog.jquery.com, blog.jquery.com, jquery.com, oracle.com, and 3 more on NVD’s record.
  4. ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.849, percentile 99.7, 31 Oct 2026.
  5. CVE Program. “CVE-2020-11023”. The official CVE record.

This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.