CVE-2023-5217
CVE-2023-5217 is a security flaw in Chrome and other Chromium browsers, the open-source browser that Chrome, Edge, Brave and Opera are built on. A booby-trapped web page can corrupt memory in Chrome and other Chromium browsers, which attackers use to take it over. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 2 Oct 2023.[1]
Chrome and other Chromium browsers is in things households have, such as phones, computers, browsers and everyday apps, so the fix matters at home as much as at work. Fixed in version 117.0.5938.132 and 1.13.1.
Description
CISA calls it a heap buffer overflow in Google Chromium libvpx. In its words: “Google Chromium libvpx contains a heap buffer overflow vulnerability in vp8 encoding that allows a remote attacker to potentially exploit heap corruption via a crafted HTML page. This vulnerability could impact web browsers using libvpx, including but not limited to Google Chrome.”[1]
The underlying weakness is out-of-bounds write (CWE-787), in MITRE’s list of common software weaknesses.[2]
It scores 8.8 out of 10 on the Common Vulnerability Scoring System, which rates it high, scored by NVD using CVSS 3.1.[2]
Affected versions
NVD’s record lists these fixed versions: in each line, everything before the version shown is affected.[2]
| Product | Fixed in |
|---|---|
| Chrome | 117.0.5938.132 |
| libvpx | 1.13.1 |
Every device with Chrome and other Chromium browsers needs the update.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 2 Oct 2023, 4 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 23 Oct 2023 to fix it.[1]
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 49%. That’s in the top 2% of the flaws it scores.[4]
CISA assesses it as not automatable: each attack takes some work.
CISA doesn’t say who was attacked, or how.
Fix
Google has published a fix or advice.[3] CISA’s required action: “Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.”[1]
- Update Chrome and other Chromium browsers now.Chrome updates itself, but only finishes when you restart it: open the menu, choose Help, then About Google Chrome, and click Relaunch. Edge, Brave, Opera and Vivaldi need the same. Then turn on automatic updates, so the next fix arrives on its own.
- Check you’re on 117.0.5938.132 or later.Fixed in version 117.0.5938.132 and 1.13.1. Anything older is what attackers are going after.
- If there’s no update, stop using it.CISA’s advice when a flaw being used in attacks has no fix is to stop using the product until it does.
Timeline
| Date | Event |
|---|---|
| The flaw is made public in the National Vulnerability Database, with a severity score of 8.8.[2] | |
| CISA adds it to its catalog of flaws known to be used in attacks.[1] | |
| CISA’s deadline for US government agencies to fix it.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at 49%.[4] |
See also
Other Google flaws
- CVE-2026-111497, Google Brotli: unchecked return value ·
- CVE-2026-58704, Google Pixel: improper authorization ·
- CVE-2026-87491, Chrome and other Chromium browsers: out of bounds write ·
- CVE-2026-85046, Chrome and other Chromium browsers: type confusion ·
- CVE-2026-11645, Chrome and other Chromium browsers: out-of-bounds read and write ·
Other out-of-bounds write flaws
- CVE-2026-86950, Apple devices: out-of-bounds write ·
- CVE-2026-53266, Linux Kernel: out-of-bounds write ·
- CVE-2026-53362, Linux Kernel: unspecified ·
- CVE-2022-0995, Linux Kernel: out-of-bounds write ·
- CVE-2026-0300, Palo Alto Networks PAN-OS: out-of-bounds write ·
Every Google flaw on CISA’s list · Everything added in October 2023
References
- ^ Cybersecurity and Infrastructure Security Agency. “Google Chromium libvpx Heap Buffer Overflow Vulnerability”. Known Exploited Vulnerabilities Catalog, added 2 Oct 2023.
- ^ National Institute of Standards and Technology. “CVE-2023-5217 Detail”. National Vulnerability Database, published 28 Sep 2023.
- ^ Google. Advisories and fixes: chromereleases.googleblog.com.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.490, percentile 98.9, 31 Oct 2026.
- CVE Program. “CVE-2023-5217”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

