CVE-2024-4577
CVE-2024-4577 is a security flaw in PHP, the programming language behind many websites. Attackers can run their own code on PHP. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 12 Jun 2024, and says ransomware gangs have used it.[1]
PHP is business software or equipment. Most families won’t have it, but attackers break into it to get inside companies, and from there to what those companies hold about their customers, patients and staff. Fixed in version 8.1.29, 8.2.20 and 8.3.8.
Description
CISA calls it a PHP-CGI OS command injection in PHP Group PHP. In its words: “PHP, specifically Windows-based PHP used in CGI mode, contains an OS command injection vulnerability that allows for arbitrary code execution. This vulnerability is a patch bypass for CVE-2012-1823.”[1]
The CVE record adds: “In PHP versions 8.1.* before 8.1.29, 8.2.* before 8.2.20, 8.3.* before 8.3.8, when using Apache and PHP-CGI on Windows, if the system is set up to use certain code pages, Windows may use "Best-Fit" behavior to replace characters in command line given to Win32 API functions. PHP CGI module may misinterpret those characters as PHP options, which may allow a malicious user to pass options to PHP binary being run, and thus reveal the source code of scripts, run arbitrary PHP code on the server, etc.”[2]
The underlying weakness is OS command injection (CWE-78), in MITRE’s list of common software weaknesses.
It scores 9.8 out of 10 on the Common Vulnerability Scoring System, which rates it critical, scored by NVD using CVSS 3.1.[2]
Affected versions
NVD’s record lists these fixed versions: in each line, everything before the version shown is affected.[2]
| Product | Fixed in |
|---|---|
| PHP | 8.1.29 |
| PHP | 8.2.20 |
| PHP | 8.3.8 |
| php | 8.1.29 |
| php | 8.2.20 |
| php | 8.3.8 |
Most families won’t have PHP; it’s for whoever looks after IT at work.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 12 Jun 2024, 3 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 3 Jul 2024 to fix it.[1] CISA says ransomware gangs have used it.
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at over 99%. That’s in the top 1% of the flaws it scores.[4]
CISA assesses it as automatable: attackers can run it against many targets at once.
CISA doesn’t say who was attacked, or how.
Fix
PHP Group has published a fix or advice.[3] CISA’s required action: “Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.”[1]
- Check whether you use it.PHP is business software or equipment, so most families won’t have it. If you run a business, or work from home on company equipment, ask whoever looks after your IT.
- Send this page to your IT person.Ask them to confirm it’s fixed (fixed in version 8.1.29, 8.2.20 and 8.3.8), or not in use. CISA gave US government agencies until 3 Jul 2024 to fix it.
- If it can’t be fixed, take it offline.CISA’s advice when there’s no fix is to stop using the product, or take it off the internet, until there is one.
You can’t fix someone else’s server, but you can watch for what follows a break-in like this: a breach notice, a password reset you didn’t ask for, or a scam message that knows things it shouldn’t. HARD watches for those for you and your family.
Timeline
| Date | Event |
|---|---|
| The flaw is made public in the National Vulnerability Database, with a severity score of 9.8.[2] | |
| CISA adds it to its catalog of flaws known to be used in attacks, noting that ransomware gangs have used it.[1] | |
| CISA’s deadline for US government agencies to fix it.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at over 99%.[4] |
See also
Other PHP flaws
- CVE-2026-109619: stale internal request-state ·
- CVE-2026-109618: memory corruption ·
Other OS command injection flaws
- CVE-2026-110447, Collabora Online – Built-in CODE Server: online – built-in CODE server OS command injection ·
- CVE-2026-106931, EG Secure Solutions SiteGuard Server Edition: OS command injection ·
- CVE-2026-83549, SonicWall SMA1000 Appliances: OS command injection ·
- CVE-2026-49869, Kestra OSS: OSS OS command injection ·
- CVE-2026-73570, Synacor Zimbra Collaboration Suite (ZCS): OS command injection ·
Added the same day
- CVE-2024-4610, Arm Mali GPU Kernel Driver: use-after-free ·
Every PHP Group flaw on CISA’s list · Everything added in June 2024
References
- ^ Cybersecurity and Infrastructure Security Agency. “PHP-CGI OS Command Injection Vulnerability”. Known Exploited Vulnerabilities Catalog, added 12 Jun 2024.
- ^ National Institute of Standards and Technology. “CVE-2024-4577 Detail”. National Vulnerability Database, published 9 Jun 2024.
- ^ PHP Group. Advisories and fixes: php.net, php.net, php.net, php.net.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 1.000, percentile 100.0, 31 Oct 2026.
- CVE Program. “CVE-2024-4577”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

