CVE-2024-51378
CVE-2024-51378 is a security flaw in CyberPersons CyberPanel. Attackers can run commands on CyberPersons CyberPanel. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 4 Dec 2024, and says ransomware gangs have used it.[1]
CyberPersons CyberPanel is business software or equipment. Most families won’t have it, but attackers break into it to get inside companies, and from there to what those companies hold about their customers, patients and staff. Fixed in version 2.3.9 of cyberpanel.
Description
CISA calls it an incorrect default permissions in CyberPersons CyberPanel. In its words: “CyberPanel contains an incorrect default permissions vulnerability that allows for authentication bypass and the execution of arbitrary commands using shell metacharacters in the statusfile property.”[1]
The CVE record adds: “getresetstatus in dns/views.py and ftp/views.py in CyberPanel (aka Cyber Panel) before 1c0c6cb allows remote attackers to bypass authentication and execute arbitrary commands via /dns/getresetstatus or /ftp/getresetstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.”[2]
The underlying weakness is CWE-276, in MITRE’s list of common software weaknesses.
It scores 9.8 out of 10 on the Common Vulnerability Scoring System, which rates it critical, scored by NVD using CVSS 3.1.[2]
Affected versions
NVD’s record lists one fixed version: everything before it is affected.[2]
| Product | Fixed in |
|---|---|
| cyberpanel | 2.3.9 |
Most families won’t have CyberPersons CyberPanel; it’s for whoever looks after IT at work.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 4 Dec 2024, 36 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 25 Dec 2024 to fix it.[1] CISA says ransomware gangs have used it.
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 95%. That’s in the top 1% of the flaws it scores.[4]
CISA assesses it as automatable: attackers can run it against many targets at once.
CISA doesn’t say who was attacked, or how.
Fix
CyberPersons has published a fix or advice.[3] CISA’s required action: “Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.”[1]
- Check whether you use it.CyberPersons CyberPanel is business software or equipment, so most families won’t have it. If you run a business, or work from home on company equipment, ask whoever looks after your IT.
- Send this page to your IT person.Ask them to confirm it’s fixed (fixed in version 2.3.9 of cyberpanel), or not in use. CISA gave US government agencies until 25 Dec 2024 to fix it.
- If it can’t be fixed, take it offline.CISA’s advice when there’s no fix is to stop using the product, or take it off the internet, until there is one.
You can’t fix someone else’s server, but you can watch for what follows a break-in like this: a breach notice, a password reset you didn’t ask for, or a scam message that knows things it shouldn’t. HARD watches for those for you and your family.
Timeline
| Date | Event |
|---|---|
| The flaw is made public in the National Vulnerability Database, with a severity score of 9.8.[2] | |
| CISA adds it to its catalog of flaws known to be used in attacks, noting that ransomware gangs have used it.[1] | |
| CISA’s deadline for US government agencies to fix it.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at 95%.[4] |
See also
Other CyberPersons CyberPanel flaws
- CVE-2024-51567: incorrect default permissions ·
Similar flaws
- CVE-2026-87886, Acronis Backup: incorrect default permissions ·
- CVE-2024-55956, Cleo products: unauthenticated file upload ·
- CVE-2022-22948, VMware vCenter Server: incorrect default file permissions ·
References
- ^ Cybersecurity and Infrastructure Security Agency. “CyberPanel Incorrect Default Permissions Vulnerability”. Known Exploited Vulnerabilities Catalog, added 4 Dec 2024.
- ^ National Institute of Standards and Technology. “CVE-2024-51378 Detail”. National Vulnerability Database, published 29 Oct 2024.
- ^ CyberPersons. Advisories and fixes: cyberpanel.net.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.947, percentile 99.9, 31 Oct 2026.
- CVE Program. “CVE-2024-51378”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

