CVE-2025-14847
CVE-2025-14847 is a security flaw in MongoDB and MongoDB Server. Attackers are using a flaw in MongoDB and MongoDB Server. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 29 Dec 2025.[1]
MongoDB and MongoDB Server is business software or equipment. Most families won’t have it, but attackers break into it to get inside companies, and from there to what those companies hold about their customers, patients and staff. Fixed in version 8.2.3, 8.0.17, 7.0.28 and 6.0.27 and others of MongoDB Server.
Description
CISA calls it an and mongoDB server improper handling of length parameter inconsistency in MongoDB MongoDB and MongoDB Server. In its words: “MongoDB Server contains an improper handling of length parameter inconsistency vulnerability in Zlib compressed protocol headers. This vulnerability may allow a read of uninitialized heap memory by an unauthenticated client.”[1]
The CVE record adds: “Mismatched length fields in Zlib compressed protocol headers may allow a read of uninitialized heap memory by an unauthenticated client. This issue affects all MongoDB Server v7.0 prior to 7.0.28 versions, MongoDB Server v8.0 versions prior to 8.0.17, MongoDB Server v8.2 versions prior to 8.2.3, MongoDB Server v6.0 versions prior to 6.0.27, MongoDB Server v5.0 versions prior to 5.0.32, MongoDB Server v4.4 versions prior to 4.4.30, MongoDB Server v4.2 versions greater than or equal to 4.2.0, MongoDB Server v4.0 versions greater than or equal to 4.0.0, and MongoDB Server v3.6 versions greater than or equal to 3.6.0.”[2]
The underlying weakness is CWE-130, in MITRE’s list of common software weaknesses.
It scores 7.5 out of 10 on the Common Vulnerability Scoring System, which rates it high, scored by the organisation that published the CVE using CVSS 3.1.[2]
Affected versions
NVD’s record lists these fixed versions: in each line, everything before the version shown is affected.[2]
| Product | Fixed in |
|---|---|
| MongoDB Server | 8.2.3 |
| MongoDB Server | 8.0.17 |
| MongoDB Server | 7.0.28 |
| MongoDB Server | 6.0.27 |
| MongoDB Server | 5.0.32 |
| MongoDB Server | 4.4.30 |
Most families won’t have MongoDB and MongoDB Server; it’s for whoever looks after IT at work.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 29 Dec 2025, 10 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 19 Jan 2026 to fix it.[1]
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 83%. That’s in the top 1% of the flaws it scores.[4]
CISA assesses it as automatable: attackers can run it against many targets at once.
CISA doesn’t say who was attacked, or how.
Fix
MongoDB has published a fix or advice.[3] CISA’s required action: “Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.”[1]
- Check whether you use it.MongoDB and MongoDB Server is business software or equipment, so most families won’t have it. If you run a business, or work from home on company equipment, ask whoever looks after your IT.
- Send this page to your IT person.Ask them to confirm it’s fixed (fixed in version 8.2.3, 8.0.17, 7.0.28 and 6.0.27 and others of MongoDB Server), or not in use. CISA gave US government agencies until 19 Jan 2026 to fix it.
- If it can’t be fixed, take it offline.CISA’s advice when there’s no fix is to stop using the product, or take it off the internet, until there is one.
You can’t fix someone else’s server, but you can watch for what follows a break-in like this: a breach notice, a password reset you didn’t ask for, or a scam message that knows things it shouldn’t. HARD watches for those for you and your family.
Timeline
| Date | Event |
|---|---|
| The flaw is made public in the National Vulnerability Database, with a severity score of 7.5.[2] | |
| CISA adds it to its catalog of flaws known to be used in attacks.[1] | |
| CISA’s deadline for US government agencies to fix it.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at 83%.[4] |
See also
Other MongoDB flaws
- CVE-2019-10758, MongoDB mongo-express: remote code execution ·
References
- ^ Cybersecurity and Infrastructure Security Agency. “MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency Vulnerability”. Known Exploited Vulnerabilities Catalog, added 29 Dec 2025.
- ^ National Institute of Standards and Technology. “CVE-2025-14847 Detail”. National Vulnerability Database, published 19 Dec 2025.
- ^ MongoDB. Advisories and fixes: jira.mongodb.org.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.832, percentile 99.7, 31 Oct 2026.
- CVE Program. “CVE-2025-14847”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

