CVE-2025-55177
CVE-2025-55177 is a security flaw in Meta Platforms WhatsApp, Meta’s messaging app. Attackers can reach parts of Meta Platforms WhatsApp that should be locked to them. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 2 Sep 2025.[1]
Meta Platforms WhatsApp is in things households have, such as phones, computers, browsers and everyday apps, so the fix matters at home as much as at work. Fixed in version 2.25.21.78 and 2.25.21.73.
Description
CISA calls it an incorrect authorization in Meta Platforms WhatsApp. In its words: “Meta Platforms WhatsApp contains an incorrect authorization vulnerability due to an incomplete authorization of linked device synchronization messages. This vulnerability could allow an unrelated user to trigger processing of content from an arbitrary URL on a target’s device.”[1]
The CVE record adds: “Incomplete authorization of linked device synchronization messages in WhatsApp for iOS prior to v2.25.21.73, WhatsApp Business for iOS v2.25.21.78, and WhatsApp for Mac v2.25.21.78 could have allowed an unrelated user to trigger processing of content from an arbitrary URL on a target’s device. We assess that this vulnerability, in combination with an OS-level vulnerability on Apple platforms (CVE-2025-43300), may have been exploited in a sophisticated attack against specific targeted users.”[2]
The underlying weakness is incorrect authorization (CWE-863), in MITRE’s list of common software weaknesses.
It scores 5.4 out of 10 on the Common Vulnerability Scoring System, which rates it medium, scored by the organisation that published the CVE using CVSS 3.1.[2]
Affected versions
NVD’s record lists these fixed versions: in each line, everything before the version shown is affected.[2]
| Product | Fixed in |
|---|---|
| WhatsApp Desktop for Mac | 2.25.21.78 |
| WhatsApp Business for iOS | 2.25.21.78 |
| WhatsApp for iOS | 2.25.21.73 |
Every device with Meta Platforms WhatsApp needs the update.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 2 Sep 2025, 4 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 23 Sep 2025 to fix it.[1]
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 14%. That’s in the top 4% of the flaws it scores.[4]
CISA assesses it as not automatable: each attack takes some work.
CISA doesn’t say who was attacked, or how.
Fix
Meta Platforms has published a fix or advice.[3] CISA’s required action: “Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.”[1]
- Update Meta Platforms WhatsApp now.Install the latest update from Meta Platforms on every device that has it, and restart when asked. Then turn on automatic updates, so the next fix arrives on its own.
- Check you’re on 2.25.21.78 or later.Fixed in version 2.25.21.78 and 2.25.21.73. Anything older is what attackers are going after.
- If there’s no update, stop using it.CISA’s advice when a flaw being used in attacks has no fix is to stop using the product until it does.
Timeline
| Date | Event |
|---|---|
| The flaw is made public in the National Vulnerability Database, with a severity score of 5.4.[2] | |
| CISA adds it to its catalog of flaws known to be used in attacks.[1] | |
| CISA’s deadline for US government agencies to fix it.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at 14%.[4] |
See also
Other Meta Platforms WhatsApp flaws
- CVE-2019-18426: cross-site scripting ·
- CVE-2019-3568: VOIP stack buffer overflow ·
Other incorrect authorization flaws
- CVE-2026-71362, Adobe Commerce and Magento: incorrect authorization ·
- CVE-2026-42016, JFrog Artifactory: incorrect authorization ·
- CVE-2025-54253, Adobe Experience Manager (AEM) Forms: experience manager forms code execution ·
- CVE-2025-21480, Qualcomm Multiple Chipsets: incorrect authorization ·
- CVE-2025-21479, Qualcomm Multiple Chipsets: incorrect authorization ·
Added the same day
- CVE-2020-24363, TP-Link TL-WA855RE: missing authentication for critical function ·
Every Meta Platforms flaw on CISA’s list · Everything added in September 2025
References
- ^ Cybersecurity and Infrastructure Security Agency. “Meta Platforms WhatsApp Incorrect Authorization Vulnerability”. Known Exploited Vulnerabilities Catalog, added 2 Sep 2025.
- ^ National Institute of Standards and Technology. “CVE-2025-55177 Detail”. National Vulnerability Database, published 29 Aug 2025.
- ^ Meta Platforms. Advisories and fixes: whatsapp.com, facebook.com.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.135, percentile 96.5, 31 Oct 2026.
- CVE Program. “CVE-2025-55177”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

