CVE-2026-105133
CVE-2026-105133 is a security flaw in AhsayCBS. Attackers can get into AhsayCBS without a valid password. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 14 Oct 2026.[1]
AhsayCBS is business software or equipment. Most families won’t have it, but attackers break into it to get inside companies, and from there to what those companies hold about their customers, patients and staff. Ahsay has published a fix or advice.
Description
CISA calls it an improper authentication in Ahsay AhsayCBS. In its words: “Ahsay AhsayCBS contains an improper authentication vulnerability that could allow a remote attacker to bypass authentication via manipulation of the random parameter in the API component’s checkSysPwd function. This vulnerability can be chained with CVE-2026-105134.”[1]
The CVE record adds: “A vulnerability was detected in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This affects the function checkSysPwd of the file com/ahsay/obs/api/ApiStructsAction.java of the component API. Performing a manipulation of the argument random results in improper authentication. It is possible to initiate the attack remotely. The exploit is now public and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to mitigate this issue. It is recommended to upgrade the affected component. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.”[2]
The underlying weakness is improper authentication (CWE-287), in MITRE’s list of common software weaknesses.
It scores 7.3 out of 10 on the Common Vulnerability Scoring System, which rates it high, scored by the organisation that published the CVE using CVSS 3.1.[2]
Affected versions
NVD’s record doesn’t list version ranges for it; Ahsay’s advisory has them[3]. CISA names the product as Ahsay AhsayCBS.
Most families won’t have AhsayCBS; it’s for whoever looks after IT at work.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 14 Oct 2026, 10 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 17 Oct 2026 to fix it.[1]
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 79%. That’s in the top 1% of the flaws it scores.[4]
CISA assesses it as automatable: attackers can run it against many targets at once.
CISA doesn’t say who was attacked, or how.
Fix
Ahsay has published a fix or advice.[3] CISA’s required action: “Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes).”[1]
- Check whether you use it.AhsayCBS is business software or equipment, so most families won’t have it. If you run a business, or work from home on company equipment, ask whoever looks after your IT.
- Send this page to your IT person.Ask them to confirm it’s fixed, or not in use. CISA gave US government agencies until 17 Oct 2026 to fix it.
- If it can’t be fixed, take it offline.CISA’s advice when there’s no fix is to stop using the product, or take it off the internet, until there is one.
You can’t fix someone else’s server, but you can watch for what follows a break-in like this: a breach notice, a password reset you didn’t ask for, or a scam message that knows things it shouldn’t. HARD watches for those for you and your family.
Timeline
| Date | Event |
|---|---|
| The flaw is made public in the National Vulnerability Database, with a severity score of 7.3.[2] | |
| CISA adds it to its catalog of flaws known to be used in attacks.[1] | |
| CISA’s deadline for US government agencies to fix it.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at 79%.[4] |
See also
Other AhsayCBS flaws
- CVE-2026-105134: command injection ·
Other improper authentication flaws
- CVE-2026-42018, JFrog Artifactory: improper authentication ·
- CVE-2026-82329, JFrog Artifactory: improper authentication ·
- CVE-2026-59822, BerriAI LiteLLM: improper authentication ·
- CVE-2023-49105, ownCloud: improper authentication ·
- CVE-2026-65400, Apple macOS: improper authentication ·
Added the same day
- CVE-2026-76519, Cisco Secure Email Gateway: relative path traversal ·
- CVE-2026-105134, AhsayCBS: command injection ·
- CVE-2026-0322, Palo Alto Networks PAN-OS: code injection ·
References
- ^ Cybersecurity and Infrastructure Security Agency. “Ahsay AhsayCBS Improper Authentication Vulnerability”. Known Exploited Vulnerabilities Catalog, added 14 Oct 2026.
- ^ National Institute of Standards and Technology. “CVE-2026-105133 Detail”. National Vulnerability Database, published 4 Oct 2026.
- ^ Ahsay. Advisories and fixes: ahsay.com.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.795, percentile 99.6, 31 Oct 2026.
- CVE Program. “CVE-2026-105133”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

