CVE-2026-42271

From Exploited flaws, HARD’s guide to the flaws being used in attacks · Checked
This article is about a flaw in BerriAI LiteLLM. For every flaw being used in attacks, see Exploited flaws; for BerriAI’s, see BerriAI flaws being used in attacks.

CVE-2026-42271 is a security flaw in BerriAI LiteLLM, a tool for building AI apps. Someone who already has a way in can use BerriAI LiteLLM to run their own code. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 8 Jun 2026.[1]

BerriAI LiteLLM is business software or equipment. Most families won’t have it, but attackers break into it to get inside companies, and from there to what those companies hold about their customers, patients and staff. BerriAI has published a fix or advice.

Description

CISA calls it a command injection in BerriAI LiteLLM. In its words: “BerriAI LiteLLM contains a command injection vulnerability that could allow any authenticated user, including holders of low-privilege internal-user keys, to run arbitrary commands on the host.”[1]

The CVE record adds: “LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.”[2]

The underlying weakness is OS command injection (CWE-78), command injection (CWE-77), in MITRE’s list of common software weaknesses.

It scores 8.8 out of 10 on the Common Vulnerability Scoring System, which rates it high, scored by NVD using CVSS 3.1.[2]

Affected versions

NVD’s record doesn’t list version ranges for it; BerriAI’s advisory has them[3]. CISA names the product as BerriAI LiteLLM.

Most families won’t have BerriAI LiteLLM; it’s for whoever looks after IT at work.

Exploitation

CISA added it to its catalog of known exploited vulnerabilities on 8 Jun 2026, 31 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 22 Jun 2026 to fix it.[1]

FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 91%. That’s in the top 1% of the flaws it scores.[4]

CISA assesses it as not automatable: each attack takes some work.

CISA doesn’t say who was attacked, or how.

Fix

BerriAI has published a fix or advice.[3] CISA’s required action: “Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.”[1]

  1. Check whether you use it.BerriAI LiteLLM is business software or equipment, so most families won’t have it. If you run a business, or work from home on company equipment, ask whoever looks after your IT.
  2. Send this page to your IT person.Ask them to confirm it’s fixed, or not in use. CISA gave US government agencies until 22 Jun 2026 to fix it.
  3. If it can’t be fixed, take it offline.CISA’s advice when there’s no fix is to stop using the product, or take it off the internet, until there is one.

You can’t fix someone else’s server, but you can watch for what follows a break-in like this: a breach notice, a password reset you didn’t ask for, or a scam message that knows things it shouldn’t. HARD watches for those for you and your family.

Timeline

DateEvent
The flaw is made public in the National Vulnerability Database, with a severity score of 8.8.[2]
CISA adds it to its catalog of flaws known to be used in attacks.[1]
CISA’s deadline for US government agencies to fix it.[1]
FIRST puts the odds of it being used in attacks in the next 30 days at 91%.[4]

See also

Other BerriAI LiteLLM flaws

Other OS command injection flaws

  • CVE-2026-110447, Collabora Online – Built-in CODE Server: online – built-in CODE server OS command injection ·
  • CVE-2026-106931, EG Secure Solutions SiteGuard Server Edition: OS command injection ·
  • CVE-2026-83549, SonicWall SMA1000 Appliances: OS command injection ·
  • CVE-2026-49869, Kestra OSS: OSS OS command injection ·
  • CVE-2026-73570, Synacor Zimbra Collaboration Suite (ZCS): OS command injection ·

Added the same day

  • CVE-2026-50751, Check Point Security Gateway: improper authentication ·

Every BerriAI flaw on CISA’s list · Everything added in June 2026

References

  1. ^ Cybersecurity and Infrastructure Security Agency. “BerriAI LiteLLM Command Injection Vulnerability”. Known Exploited Vulnerabilities Catalog, added 8 Jun 2026.
  2. ^ National Institute of Standards and Technology. “CVE-2026-42271 Detail”. National Vulnerability Database, published 8 May 2026.
  3. ^ BerriAI. Advisories and fixes: github.com.
  4. ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.914, percentile 99.8, 31 Oct 2026.
  5. CVE Program. “CVE-2026-42271”. The official CVE record.

This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.