CVE-2026-97229
CVE-2026-97229 is a security flaw in GitLab Community Edition and Enterprise Edition, software teams use to store and build code. Attackers can run their own code on GitLab Community Edition and Enterprise Edition from anywhere, without logging in. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 29 Oct 2026.[1]
GitLab Community Edition and Enterprise Edition is business software or equipment. Most families won’t have it, but attackers break into it to get inside companies, and from there to what those companies hold about their customers, patients and staff. Fixed in version 19.2.8, 19.3.5 and 19.4.2 of GitLab.
Description
CISA calls it an integer overflow or wraparound in GitLab Community Edition and Enterprise Edition. In its words: “GitLab Community Edition and Enterprise Edition contain a integer overflow or wraparound vulnerability that could allow an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.”[1]
The CVE record adds: “GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.”[2]
The underlying weakness is integer overflow (CWE-190), in MITRE’s list of common software weaknesses.
It scores 10.0 out of 10 on the Common Vulnerability Scoring System, which rates it critical, scored by the organisation that published the CVE using CVSS 3.1.[2]
Affected versions
NVD’s record lists these fixed versions: in each line, everything before the version shown is affected.[2]
| Product | Fixed in |
|---|---|
| GitLab | 19.2.8 |
| GitLab | 19.3.5 |
| GitLab | 19.4.2 |
Most families won’t have GitLab Community Edition and Enterprise Edition; it’s for whoever looks after IT at work.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 29 Oct 2026, 16 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 1 Nov 2026 to fix it.[1]
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 27%. That’s in the top 2% of the flaws it scores.[4]
CISA assesses it as automatable: attackers can run it against many targets at once.
CISA doesn’t say who was attacked, or how.
Fix
GitLab has published a fix or advice.[3] CISA’s required action: “Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes).”[1]
- Check whether you use it.GitLab Community Edition and Enterprise Edition is business software or equipment, so most families won’t have it. If you run a business, or work from home on company equipment, ask whoever looks after your IT.
- Send this page to your IT person.Ask them to confirm it’s fixed (fixed in version 19.2.8, 19.3.5 and 19.4.2 of GitLab), or not in use. CISA gave US government agencies until 1 Nov 2026 to fix it.
- If it can’t be fixed, take it offline.CISA’s advice when there’s no fix is to stop using the product, or take it off the internet, until there is one.
You can’t fix someone else’s server, but you can watch for what follows a break-in like this: a breach notice, a password reset you didn’t ask for, or a scam message that knows things it shouldn’t. HARD watches for those for you and your family.
Timeline
| Date | Event |
|---|---|
| The flaw is made public in the National Vulnerability Database, with a severity score of 10.0.[2] | |
| CISA adds it to its catalog of flaws known to be used in attacks.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at 27%.[4] | |
| CISA’s deadline for US government agencies to fix it.[1] |
See also
Other GitLab Community Edition and Enterprise Edition flaws
- CVE-2026-85706: path traversal ·
Other GitLab flaws
- CVE-2021-22175, GitLab: server-side request forgery (SSRF) ·
- CVE-2021-39935, GitLab Community and Enterprise Editions: server-side request forgery (SSRF) ·
- CVE-2023-7028, GitLab CE/EE: community and enterprise editions improper access control ·
- CVE-2021-22205, GitLab Community and Enterprise Editions: remote code execution ·
Other integer overflow flaws
- CVE-2025-48595, Android Framework: integer overflow ·
- CVE-2021-30952, Apple devices: integer overflow or wraparound ·
- CVE-2026-21385, Qualcomm Multiple Chipsets: memory corruption ·
- CVE-2018-14634, Linux Kernel: integer overflow ·
- CVE-2025-24985, Microsoft Windows: fast FAT file system driver integer overflow ·
Added the same day
- CVE-2026-76418, Cisco Secure Firewall ASA Software and Cisco Secure FTD Software: unchecked return value to NULL pointer dereference ·
Every GitLab flaw on CISA’s list · Everything added in October 2026
References
- ^ Cybersecurity and Infrastructure Security Agency. “GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound Vulnerability”. Known Exploited Vulnerabilities Catalog, added 29 Oct 2026.
- ^ National Institute of Standards and Technology. “CVE-2026-97229 Detail”. National Vulnerability Database, published 13 Oct 2026.
- ^ GitLab. Advisories and fixes: ruby-lang.org, docs.gitlab.com.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.273, percentile 98.1, 31 Oct 2026.
- CVE Program. “CVE-2026-97229”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

