CVE-2014-0497
CVE-2014-0497 is a security flaw in Adobe Flash Player, Adobe’s discontinued browser plug-in for animation and video. Attackers can run their own code on Adobe Flash Player. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 17 Sep 2024.[1]
Adobe Flash Player is in things households have, such as phones, computers, browsers and everyday apps, so the fix matters at home as much as at work. Fixed in version 11.7.700.261 of flash_player.
Description
CISA calls it an integer underflow vulnerablity in Adobe Flash Player. In its words: “Adobe Flash Player contains an integer underflow vulnerability that allows a remote attacker to execute arbitrary code.”[1]
The CVE record adds: “Integer underflow in Adobe Flash Player before 11.7.700.261 and 11.8.x through 12.0.x before 12.0.0.44 on Windows and Mac OS X, and before 11.2.202.336 on Linux, allows remote attackers to execute arbitrary code via unspecified vectors.”[2]
The underlying weakness is CWE-191, in MITRE’s list of common software weaknesses.
It scores 9.8 out of 10 on the Common Vulnerability Scoring System, which rates it critical, scored by NVD using CVSS 3.1.[2]
Affected versions
NVD’s record lists one fixed version: everything before it is affected.[2]
| Product | Fixed in |
|---|---|
| flash_player | 11.7.700.261 |
Every device with Adobe Flash Player needs the update.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 17 Sep 2024, 3,877 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 8 Oct 2024 to fix it.[1]
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at over 99%. That’s in the top 1% of the flaws it scores.[4]
CISA assesses it as not automatable: each attack takes some work.
CISA doesn’t say who was attacked, or how.
Fix
Adobe has published a fix or advice.[3] CISA’s required action: “The impacted product is end-of-life (EoL) and/or end-of-service (EoS).”[1]
- Update Adobe Flash Player now.Install the latest update from Adobe on every device that has it, and restart when asked. Then turn on automatic updates, so the next fix arrives on its own.
- Check you’re on 11.7.700.261 or later.Fixed in version 11.7.700.261 of flash_player. Anything older is what attackers are going after.
- If there’s no update, stop using it.CISA’s advice when a flaw being used in attacks has no fix is to stop using the product until it does.
Timeline
| Date | Event |
|---|---|
| The flaw is made public in the National Vulnerability Database, with a severity score of 9.8.[2] | |
| CISA adds it to its catalog of flaws known to be used in attacks.[1] | |
| CISA’s deadline for US government agencies to fix it.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at over 99%.[4] |
See also
Other Adobe Flash Player flaws
- CVE-2014-0502: double free vulnerablity ·
- CVE-2013-0648: code execution ·
- CVE-2013-0643: incorrect default permissions ·
- CVE-2012-5054: integer overflow ·
- CVE-2012-0767: cross-site scripting (XSS) ·
- CVE-2012-0754: memory corruption ·
Other Adobe flaws
- CVE-2026-48356, Adobe Commerce and Magento: unrestricted upload of file with dangerous type ·
- CVE-2026-71362, Adobe Commerce and Magento: incorrect authorization ·
- CVE-2026-75650, Adobe Commerce and Magento: improper neutralization of special elements used in a template engine ·
- CVE-2026-48282, Adobe ColdFusion: path traversal ·
- CVE-2009-3459, Adobe Acrobat and Reader: heap-based buffer overflow ·
Similar flaws
- CVE-2021-31956, Microsoft Windows: NTFS privilege escalation ·
Added the same day
- CVE-2014-0502, Adobe Flash Player: double free vulnerablity ·
- CVE-2013-0648, Adobe Flash Player: code execution ·
- CVE-2013-0643, Adobe Flash Player: incorrect default permissions ·
Every Adobe flaw on CISA’s list · Everything added in September 2024
References
- ^ Cybersecurity and Infrastructure Security Agency. “Adobe Flash Player Integer Underflow Vulnerablity”. Known Exploited Vulnerabilities Catalog, added 17 Sep 2024.
- ^ National Institute of Standards and Technology. “CVE-2014-0497 Detail”. National Vulnerability Database, published 5 Feb 2014.
- ^ Adobe. Advisories and fixes: adobe.com.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.999, percentile 100.0, 31 Oct 2026.
- CVE Program. “CVE-2014-0497”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

