CVE-2014-0502
CVE-2014-0502 is a security flaw in Adobe Flash Player, Adobe’s discontinued browser plug-in for animation and video. Attackers can run their own code on Adobe Flash Player. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 17 Sep 2024.[1]
Adobe Flash Player is in things households have, such as phones, computers, browsers and everyday apps, so the fix matters at home as much as at work. Fixed in version 11.7.700.269, 12.0.0.70 and 4.0.0.1628.
Description
CISA calls it a double free vulnerablity in Adobe Flash Player. In its words: “Adobe Flash Player contains a double free vulnerability that allows a remote attacker to execute arbitrary code.”[1]
The CVE record adds: “Double free vulnerability in Adobe Flash Player before 11.7.700.269 and 11.8.x through 12.0.x before 12.0.0.70 on Windows and Mac OS X and before 11.2.202.341 on Linux, Adobe AIR before 4.0.0.1628 on Android, Adobe AIR SDK before 4.0.0.1628, and Adobe AIR SDK & Compiler before 4.0.0.1628 allows remote attackers to execute arbitrary code via unspecified vectors, as exploited in the wild in February 2014.”[2]
The underlying weakness is CWE-399, in MITRE’s list of common software weaknesses.
It scores 8.8 out of 10 on the Common Vulnerability Scoring System, which rates it high, scored by NVD using CVSS 3.1.[2]
Affected versions
NVD’s record lists these fixed versions: in each line, everything before the version shown is affected.[2]
| Product | Fixed in |
|---|---|
| flash_player | 11.7.700.269 |
| flash_player | 12.0.0.70 |
| air | 4.0.0.1628 |
| air_sdk | 4.0.0.1628 |
Every device with Adobe Flash Player needs the update.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 17 Sep 2024, 3,861 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 8 Oct 2024 to fix it.[1]
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 25%. That’s in the top 3% of the flaws it scores.[4]
CISA assesses it as automatable: attackers can run it against many targets at once.
CISA doesn’t say who was attacked, or how.
Fix
Adobe has published a fix or advice.[3] CISA’s required action: “The impacted product is end-of-life (EoL) and/or end-of-service (EoS).”[1]
- Update Adobe Flash Player now.Install the latest update from Adobe on every device that has it, and restart when asked. Then turn on automatic updates, so the next fix arrives on its own.
- Check you’re on 11.7.700.269 or later.Fixed in version 11.7.700.269, 12.0.0.70 and 4.0.0.1628. Anything older is what attackers are going after.
- If there’s no update, stop using it.CISA’s advice when a flaw being used in attacks has no fix is to stop using the product until it does.
Timeline
| Date | Event |
|---|---|
| The flaw is made public in the National Vulnerability Database, with a severity score of 8.8.[2] | |
| CISA adds it to its catalog of flaws known to be used in attacks.[1] | |
| CISA’s deadline for US government agencies to fix it.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at 25%.[4] |
See also
Other Adobe Flash Player flaws
- CVE-2014-0497: integer underflow vulnerablity ·
- CVE-2013-0648: code execution ·
- CVE-2013-0643: incorrect default permissions ·
- CVE-2012-5054: integer overflow ·
- CVE-2012-0767: cross-site scripting (XSS) ·
- CVE-2012-0754: memory corruption ·
Other Adobe flaws
- CVE-2026-48356, Adobe Commerce and Magento: unrestricted upload of file with dangerous type ·
- CVE-2026-71362, Adobe Commerce and Magento: incorrect authorization ·
- CVE-2026-75650, Adobe Commerce and Magento: improper neutralization of special elements used in a template engine ·
- CVE-2026-48282, Adobe ColdFusion: path traversal ·
- CVE-2009-3459, Adobe Acrobat and Reader: heap-based buffer overflow ·
Similar flaws
- CVE-2010-0806, Microsoft Internet Explorer: use-after-free ·
- CVE-2013-3893, Microsoft Internet Explorer: resource management errors ·
- CVE-2012-2539, Microsoft Word: remote code execution ·
- CVE-2018-0180, Cisco IOS Software: denial-of-service ·
- CVE-2018-0179, Cisco IOS Software: denial-of-service ·
Added the same day
- CVE-2014-0497, Adobe Flash Player: integer underflow vulnerablity ·
- CVE-2013-0648, Adobe Flash Player: code execution ·
- CVE-2013-0643, Adobe Flash Player: incorrect default permissions ·
Every Adobe flaw on CISA’s list · Everything added in September 2024
References
- ^ Cybersecurity and Infrastructure Security Agency. “Adobe Flash Player Double Free Vulnerablity”. Known Exploited Vulnerabilities Catalog, added 17 Sep 2024.
- ^ National Institute of Standards and Technology. “CVE-2014-0502 Detail”. National Vulnerability Database, published 21 Feb 2014.
- ^ Adobe. Advisories and fixes: adobe.com.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.248, percentile 97.9, 31 Oct 2026.
- CVE Program. “CVE-2014-0502”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

