CVE-2024-45195
CVE-2024-45195 is a security flaw in Apache OFBiz, open-source software from the Apache Software Foundation. Attackers are using a flaw in Apache OFBiz. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 4 Feb 2025.[1]
Apache OFBiz is business software or equipment. Most families won’t have it, but attackers break into it to get inside companies, and from there to what those companies hold about their customers, patients and staff. Fixed in version 18.12.16.
Description
CISA calls it a forced browsing in Apache OFBiz. In its words: “Apache OFBiz contains a forced browsing vulnerability that allows a remote attacker to obtain unauthorized access.”[1]
The CVE record adds: “Direct Request ('Forced Browsing') vulnerability in Apache OFBiz. This issue affects Apache OFBiz: before 18.12.16. Users are recommended to upgrade to version 18.12.16, which fixes the issue.”[2]
The underlying weakness is CWE-425, in MITRE’s list of common software weaknesses.
It scores 7.5 out of 10 on the Common Vulnerability Scoring System, which rates it high, scored by NVD using CVSS 3.1.[2]
Affected versions
NVD’s record lists these fixed versions: in each line, everything before the version shown is affected.[2]
| Product | Fixed in |
|---|---|
| Apache OFBiz | 18.12.16 |
| ofbiz | 18.12.16 |
Most families won’t have Apache OFBiz; it’s for whoever looks after IT at work.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 4 Feb 2025, 153 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 25 Feb 2025 to fix it.[1]
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at over 99%. That’s in the top 1% of the flaws it scores.[4]
CISA assesses it as automatable: attackers can run it against many targets at once.
CISA doesn’t say who was attacked, or how.
Fix
Apache has published a fix or advice.[3] CISA’s required action: “Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.”[1]
- Check whether you use it.Apache OFBiz is business software or equipment, so most families won’t have it. If you run a business, or work from home on company equipment, ask whoever looks after your IT.
- Send this page to your IT person.Ask them to confirm it’s fixed (fixed in version 18.12.16), or not in use. CISA gave US government agencies until 25 Feb 2025 to fix it.
- If it can’t be fixed, take it offline.CISA’s advice when there’s no fix is to stop using the product, or take it off the internet, until there is one.
You can’t fix someone else’s server, but you can watch for what follows a break-in like this: a breach notice, a password reset you didn’t ask for, or a scam message that knows things it shouldn’t. HARD watches for those for you and your family.
Timeline
| Date | Event |
|---|---|
| The flaw is made public in the National Vulnerability Database, with a severity score of 7.5.[2] | |
| CISA adds it to its catalog of flaws known to be used in attacks.[1] | |
| CISA’s deadline for US government agencies to fix it.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at over 99%.[4] |
See also
Other Apache OFBiz flaws
- CVE-2024-38856: incorrect authorization ·
- CVE-2024-32113: path traversal ·
Other Apache flaws
- CVE-2016-3081, Apache Struts: command injection ·
- CVE-2026-34486, Apache Tomcat: missing encryption of sensitive data ·
- CVE-2026-34197, Apache ActiveMQ: improper input validation ·
- CVE-2024-38475, Apache HTTP Server: improper escaping of output ·
- CVE-2025-24813, Apache Tomcat: path equivalence ·
Similar flaws
- CVE-2021-26085, Atlassian Confluence Server: pre-authorization arbitrary file read ·
Added the same day
- CVE-2024-29059, Microsoft .NET Framework: information disclosure ·
- CVE-2018-9276, Paessler PRTG Network Monitor: OS command injection ·
- CVE-2018-19410, Paessler PRTG Network Monitor: local file inclusion ·
Every Apache flaw on CISA’s list · Everything added in February 2025
References
- ^ Cybersecurity and Infrastructure Security Agency. “Apache OFBiz Forced Browsing Vulnerability”. Known Exploited Vulnerabilities Catalog, added 4 Feb 2025.
- ^ National Institute of Standards and Technology. “CVE-2024-45195 Detail”. National Vulnerability Database, published 4 Sep 2024.
- ^ Apache. Advisories and fixes: ofbiz.apache.org, issues.apache.org, lists.apache.org.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 1.000, percentile 100.0, 31 Oct 2026.
- CVE Program. “CVE-2024-45195”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

