CVE-2024-38856
CVE-2024-38856 is a security flaw in Apache OFBiz, open-source software from the Apache Software Foundation. Attackers can run their own code on Apache OFBiz from anywhere, without logging in. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 27 Aug 2024.[1]
Apache OFBiz is business software or equipment. Most families won’t have it, but attackers break into it to get inside companies, and from there to what those companies hold about their customers, patients and staff. Apache has published a fix or advice.
Description
CISA calls it an incorrect authorization in Apache OFBiz. In its words: “Apache OFBiz contains an incorrect authorization vulnerability that could allow remote code execution via a Groovy payload in the context of the OFBiz user process by an unauthenticated attacker.”[1]
The CVE record adds: “Incorrect Authorization vulnerability in Apache OFBiz. This issue affects Apache OFBiz: through 18.12.14. Users are recommended to upgrade to version 18.12.15, which fixes the issue. Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).”[2]
The underlying weakness is incorrect authorization (CWE-863), in MITRE’s list of common software weaknesses.
It scores 9.8 out of 10 on the Common Vulnerability Scoring System, which rates it critical, scored by NVD using CVSS 3.1.[2]
Affected versions
NVD’s record doesn’t list version ranges for it; Apache’s advisory has them[3]. CISA names the product as Apache OFBiz.
Most families won’t have Apache OFBiz; it’s for whoever looks after IT at work.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 27 Aug 2024, 22 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 17 Sep 2024 to fix it.[1]
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 99%. That’s in the top 1% of the flaws it scores.[4]
CISA assesses it as automatable: attackers can run it against many targets at once.
CISA doesn’t say who was attacked, or how.
Fix
Apache has published a fix or advice.[3] CISA’s required action: “Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.”[1]
- Check whether you use it.Apache OFBiz is business software or equipment, so most families won’t have it. If you run a business, or work from home on company equipment, ask whoever looks after your IT.
- Send this page to your IT person.Ask them to confirm it’s fixed, or not in use. CISA gave US government agencies until 17 Sep 2024 to fix it.
- If it can’t be fixed, take it offline.CISA’s advice when there’s no fix is to stop using the product, or take it off the internet, until there is one.
You can’t fix someone else’s server, but you can watch for what follows a break-in like this: a breach notice, a password reset you didn’t ask for, or a scam message that knows things it shouldn’t. HARD watches for those for you and your family.
Timeline
| Date | Event |
|---|---|
| The flaw is made public in the National Vulnerability Database, with a severity score of 9.8.[2] | |
| CISA adds it to its catalog of flaws known to be used in attacks.[1] | |
| CISA’s deadline for US government agencies to fix it.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at 99%.[4] |
See also
Other Apache OFBiz flaws
- CVE-2024-45195: forced browsing ·
- CVE-2024-32113: path traversal ·
Other Apache flaws
- CVE-2016-3081, Apache Struts: command injection ·
- CVE-2026-34486, Apache Tomcat: missing encryption of sensitive data ·
- CVE-2026-34197, Apache ActiveMQ: improper input validation ·
- CVE-2024-38475, Apache HTTP Server: improper escaping of output ·
- CVE-2025-24813, Apache Tomcat: path equivalence ·
Other incorrect authorization flaws
- CVE-2026-71362, Adobe Commerce and Magento: incorrect authorization ·
- CVE-2026-42016, JFrog Artifactory: incorrect authorization ·
- CVE-2025-54253, Adobe Experience Manager (AEM) Forms: experience manager forms code execution ·
- CVE-2025-55177, Meta Platforms WhatsApp: incorrect authorization ·
- CVE-2025-21480, Qualcomm Multiple Chipsets: incorrect authorization ·
Every Apache flaw on CISA’s list · Everything added in August 2024
References
- ^ Cybersecurity and Infrastructure Security Agency. “Apache OFBiz Incorrect Authorization Vulnerability”. Known Exploited Vulnerabilities Catalog, added 27 Aug 2024.
- ^ National Institute of Standards and Technology. “CVE-2024-38856 Detail”. National Vulnerability Database, published 5 Aug 2024.
- ^ Apache. Advisories and fixes: lists.apache.org, ofbiz.apache.org.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.994, percentile 99.9, 31 Oct 2026.
- CVE Program. “CVE-2024-38856”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

