CVE-2025-10585
CVE-2025-10585 is a security flaw in Chrome and other Chromium browsers, the JavaScript engine inside Chrome, Edge, Brave, Opera and other Chromium browsers. A booby-trapped web page can corrupt memory in Chrome and other Chromium browsers, which attackers use to take it over. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 23 Sep 2025.[1]
Chrome and other Chromium browsers is in things households have, such as phones, computers, browsers and everyday apps, so the fix matters at home as much as at work. Fixed in version 140.0.7339.185 of Chrome.
Description
CISA calls it a type confusion in Google Chromium V8. In its words: “Google Chromium contains a type confusion vulnerability in the V8 JavaScript and WebAssembly engine.”[1]
The CVE record adds: “Type confusion in V8 in Google Chrome prior to 140.0.7339.185 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)”[2]
The underlying weakness is type confusion (CWE-843), in MITRE’s list of common software weaknesses.
It scores 9.8 out of 10 on the Common Vulnerability Scoring System, which rates it critical, scored by NVD using CVSS 3.1.[2]
Affected versions
NVD’s record lists one fixed version: everything before it is affected.[2]
| Product | Fixed in |
|---|---|
| Chrome | 140.0.7339.185 |
Every device with Chrome and other Chromium browsers needs the update.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 23 Sep 2025. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 14 Oct 2025 to fix it.[1]
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 9%. That’s in the top 5% of the flaws it scores.[4]
CISA assesses it as not automatable: each attack takes some work.
CISA doesn’t say who was attacked, or how.
Fix
Google has published a fix or advice.[3] CISA’s required action: “Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.”[1]
- Update Chrome and other Chromium browsers now.Chrome updates itself, but only finishes when you restart it: open the menu, choose Help, then About Google Chrome, and click Relaunch. Edge, Brave, Opera and Vivaldi need the same. Then turn on automatic updates, so the next fix arrives on its own.
- Check you’re on 140.0.7339.185 or later.Fixed in version 140.0.7339.185 of Chrome. Anything older is what attackers are going after.
- If there’s no update, stop using it.CISA’s advice when a flaw being used in attacks has no fix is to stop using the product until it does.
Timeline
| Date | Event |
|---|---|
| CISA adds it to its catalog of flaws known to be used in attacks.[1] | |
| The flaw is made public in the National Vulnerability Database, with a severity score of 9.8.[2] | |
| CISA’s deadline for US government agencies to fix it.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at 9%.[4] |
See also
Other Chrome and other Chromium browsers flaws
- CVE-2026-87491: out of bounds write ·
- CVE-2026-85046: type confusion ·
- CVE-2026-11645: out-of-bounds read and write ·
- CVE-2026-3910: improper restriction of operations within the bounds of a memory buffer ·
- CVE-2025-13223: type confusion ·
- CVE-2025-6554: type confusion ·
Other type confusion flaws
- CVE-2026-21519, Microsoft Windows: type confusion ·
- CVE-2025-30397, Microsoft Windows: scripting engine type confusion ·
- CVE-2024-38178, Microsoft Windows: scripting engine memory corruption ·
- CVE-2024-23222, Apple devices: webKit type confusion ·
- CVE-2023-32439, Apple devices: webKit type confusion ·
Every Google flaw on CISA’s list · Everything added in September 2025
References
- ^ Cybersecurity and Infrastructure Security Agency. “Google Chromium V8 Type Confusion Vulnerability”. Known Exploited Vulnerabilities Catalog, added 23 Sep 2025.
- ^ National Institute of Standards and Technology. “CVE-2025-10585 Detail”. National Vulnerability Database, published 24 Sep 2025.
- ^ Google. Advisories and fixes: chromereleases.googleblog.com.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.090, percentile 95.3, 31 Oct 2026.
- CVE Program. “CVE-2025-10585”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

