CVE-2026-3910

From Exploited flaws, HARD’s guide to the flaws being used in attacks · Checked
This article is about a flaw in Chrome and other Chromium browsers. For every flaw being used in attacks, see Exploited flaws; for Google’s, see Google flaws being used in attacks.

CVE-2026-3910 is a security flaw in Chrome and other Chromium browsers, the JavaScript engine inside Chrome, Edge, Brave, Opera and other Chromium browsers. A booby-trapped web page can run an attacker's code through Chrome and other Chromium browsers. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 13 Mar 2026.[1]

Chrome and other Chromium browsers is in things households have, such as phones, computers, browsers and everyday apps, so the fix matters at home as much as at work. Fixed in version 146.0.7680.75 of Chrome.

Description

CISA calls it an improper restriction of operations within the bounds of a memory buffer in Google Chromium V8. In its words: “Google Chromium V8 contains an improper restriction of operations within the bounds of a memory buffer vulnerability that could allow a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page. This vulnerability could affect multiple web browsers that utilize Chromium, including, but not limited to, Google Chrome, Microsoft Edge, and Opera.”[1]

The underlying weakness is memory buffer error (CWE-119), in MITRE’s list of common software weaknesses.[2]

It scores 8.8 out of 10 on the Common Vulnerability Scoring System, which rates it high, scored by NVD using CVSS 3.1.[2]

Affected versions

NVD’s record lists one fixed version: everything before it is affected.[2]

ProductFixed in
Chrome146.0.7680.75

Every device with Chrome and other Chromium browsers needs the update.

Exploitation

CISA added it to its catalog of known exploited vulnerabilities on 13 Mar 2026, within a day of it being made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 27 Mar 2026 to fix it.[1]

FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 3%. That’s in the top 15% of the flaws it scores.[4]

CISA assesses it as not automatable: each attack takes some work.

CISA doesn’t say who was attacked, or how.

Fix

Google has published a fix or advice.[3] CISA’s required action: “Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.”[1]

  1. Update Chrome and other Chromium browsers now.Chrome updates itself, but only finishes when you restart it: open the menu, choose Help, then About Google Chrome, and click Relaunch. Edge, Brave, Opera and Vivaldi need the same. Then turn on automatic updates, so the next fix arrives on its own.
  2. Check you’re on 146.0.7680.75 or later.Fixed in version 146.0.7680.75 of Chrome. Anything older is what attackers are going after.
  3. If there’s no update, stop using it.CISA’s advice when a flaw being used in attacks has no fix is to stop using the product until it does.

Timeline

DateEvent
The flaw is made public in the National Vulnerability Database, with a severity score of 8.8.[2]
CISA adds it to its catalog of flaws known to be used in attacks.[1]
CISA’s deadline for US government agencies to fix it.[1]
FIRST puts the odds of it being used in attacks in the next 30 days at 3%.[4]

See also

Other Chrome and other Chromium browsers flaws

Other memory buffer error flaws

  • CVE-2026-88779, Citrix NetScaler: improper restriction of operations within the bounds of a memory buffer ·
  • CVE-2026-88772, Citrix NetScaler: improper restriction of operations within the bounds of a memory buffer ·
  • CVE-2026-88771, Citrix NetScaler: improper input validation ·
  • CVE-2026-8452, Citrix NetScaler ADC and NetScaler Gateway: improper restriction of operations within the bounds of a memory buffer ·
  • CVE-2009-3459, Adobe Acrobat and Reader: heap-based buffer overflow ·

Added the same day

Every Google flaw on CISA’s list · Everything added in March 2026

References

  1. ^ Cybersecurity and Infrastructure Security Agency. “Google Chromium V8 Improper Restriction of Operations Within the Bounds of a Memory Buffer Vulnerability”. Known Exploited Vulnerabilities Catalog, added 13 Mar 2026.
  2. ^ National Institute of Standards and Technology. “CVE-2026-3910 Detail”. National Vulnerability Database, published 13 Mar 2026.
  3. ^ Google. Advisories and fixes: chromereleases.googleblog.com.
  4. ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.027, percentile 85.9, 31 Oct 2026.
  5. CVE Program. “CVE-2026-3910”. The official CVE record.

This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.