CVE-2025-58360

From Exploited flaws, HARD’s guide to the flaws being used in attacks · Checked
This article is about a flaw in OSGeo GeoServer. For every flaw being used in attacks, see Exploited flaws; for OSGeo’s, see OSGeo flaws being used in attacks.

CVE-2025-58360 is a security flaw in OSGeo GeoServer. Attackers can read files on OSGeo GeoServer that should be out of reach. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 11 Dec 2025.[1]

OSGeo GeoServer is business software or equipment. Most families won’t have it, but attackers break into it to get inside companies, and from there to what those companies hold about their customers, patients and staff. OSGeo has published a fix or advice.

Description

CISA calls it an improper restriction of XML external entity reference in OSGeo GeoServer. In its words: “OSGeo GeoServer contains an improper restriction of XML external entity reference vulnerability that occurs when the application accepts XML input through a specific endpoint /geoserver/wms operation GetMap and could allow an attacker to define external entities within the XML request.”[1]

The CVE record adds: “GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.”[2]

The underlying weakness is XML external entity (CWE-611), in MITRE’s list of common software weaknesses.

It scores 9.8 out of 10 on the Common Vulnerability Scoring System, which rates it critical, scored by NVD using CVSS 3.1.[2]

Affected versions

NVD’s record doesn’t list version ranges for it; OSGeo’s advisory has them[3]. CISA names the product as OSGeo GeoServer.

Most families won’t have OSGeo GeoServer; it’s for whoever looks after IT at work.

Exploitation

CISA added it to its catalog of known exploited vulnerabilities on 11 Dec 2025, 16 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 1 Jan 2026 to fix it.[1]

FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 61%. That’s in the top 1% of the flaws it scores.[4]

CISA assesses it as automatable: attackers can run it against many targets at once.

CISA doesn’t say who was attacked, or how.

Fix

OSGeo has published a fix or advice.[3] CISA’s required action: “Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.”[1]

  1. Check whether you use it.OSGeo GeoServer is business software or equipment, so most families won’t have it. If you run a business, or work from home on company equipment, ask whoever looks after your IT.
  2. Send this page to your IT person.Ask them to confirm it’s fixed, or not in use. CISA gave US government agencies until 1 Jan 2026 to fix it.
  3. If it can’t be fixed, take it offline.CISA’s advice when there’s no fix is to stop using the product, or take it off the internet, until there is one.

You can’t fix someone else’s server, but you can watch for what follows a break-in like this: a breach notice, a password reset you didn’t ask for, or a scam message that knows things it shouldn’t. HARD watches for those for you and your family.

Timeline

DateEvent
The flaw is made public in the National Vulnerability Database, with a severity score of 9.8.[2]
CISA adds it to its catalog of flaws known to be used in attacks.[1]
CISA’s deadline for US government agencies to fix it.[1]
FIRST puts the odds of it being used in attacks in the next 30 days at 61%.[4]

See also

Other OSGeo GeoServer flaws

Other OSGeo flaws

  • CVE-2022-24816, OSGeo JAI-EXT: geoServer JAI-EXT code injection ·

Other XML external entity flaws

  • CVE-2025-2776, SysAid On-Prem: on-prem improper restriction of XML external entity reference ·
  • CVE-2025-2775, SysAid On-Prem: on-prem improper restriction of XML external entity reference ·
  • CVE-2023-45727, North Grid Proself: improper restriction of XML external entity (XXE) reference ·
  • CVE-2024-34102, Adobe Commerce and Magento Open Source: improper restriction of XML external entity reference (XXE) ·
  • CVE-2019-9670, Synacor Zimbra Collaboration Suite (ZCS): improper restriction of XML external entity reference ·

Every OSGeo flaw on CISA’s list · Everything added in December 2025

References

  1. ^ Cybersecurity and Infrastructure Security Agency. “OSGeo GeoServer Improper Restriction of XML External Entity Reference Vulnerability”. Known Exploited Vulnerabilities Catalog, added 11 Dec 2025.
  2. ^ National Institute of Standards and Technology. “CVE-2025-58360 Detail”. National Vulnerability Database, published 25 Nov 2025.
  3. ^ OSGeo. Advisories and fixes: github.com, osgeo-org.atlassian.net.
  4. ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.612, percentile 99.2, 31 Oct 2026.
  5. CVE Program. “CVE-2025-58360”. The official CVE record.

This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.