CVE-2024-36401
CVE-2024-36401 is a security flaw in OSGeo GeoServer. Attackers can run their own code on OSGeo GeoServer from anywhere, without logging in. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 15 Jul 2024.[1]
OSGeo GeoServer is business software or equipment. Most families won’t have it, but attackers break into it to get inside companies, and from there to what those companies hold about their customers, patients and staff. Fixed in version 2.23.6, 2.24.4 and 2.25.2 of geoserver.
Description
CISA calls it a geoTools eval injection in OSGeo GeoServer. In its words: “OSGeo GeoServer GeoTools contains an improper neutralization of directives in dynamically evaluated code vulnerability due to unsafely evaluating property names as XPath expressions. This allows unauthenticated attackers to conduct remote code execution via specially crafted input.”[1]
The CVE record adds: “GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.22.6, 2.23.6, 2.24.4, and 2.25.2, multiple OGC request parameters allow Remote Code Execution (RCE) by unauthenticated users through specially crafted input against a default GeoServer installation due to unsafely evaluating property names as XPath expressions. The GeoTools library API that GeoServer calls evaluates property/attribute names for feature types in a way that unsafely passes them to the commons-jxpath library which can execute arbitrary code when evaluating XPath expressions. This XPath evaluation is intended to be used only by complex feature types (i.e., Application Schema data stores) but is incorrectly being applied to simple feature types as well which makes this vulnerability apply to **ALL** GeoServer instances. No public PoC is provided…”[2]
The underlying weakness is CWE-95, in MITRE’s list of common software weaknesses.
It scores 9.8 out of 10 on the Common Vulnerability Scoring System, which rates it critical, scored by NVD using CVSS 3.1.[2]
Affected versions
NVD’s record lists these fixed versions: in each line, everything before the version shown is affected.[2]
| Product | Fixed in |
|---|---|
| geoserver | 2.23.6 |
| geoserver | 2.24.4 |
| geoserver | 2.25.2 |
Most families won’t have OSGeo GeoServer; it’s for whoever looks after IT at work.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 15 Jul 2024, 14 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 5 Aug 2024 to fix it.[1]
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at over 99%. That’s in the top 1% of the flaws it scores.[4]
CISA assesses it as automatable: attackers can run it against many targets at once.
CISA doesn’t say who was attacked, or how.
Fix
OSGeo has published a fix or advice.[3] CISA’s required action: “Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.”[1]
- Check whether you use it.OSGeo GeoServer is business software or equipment, so most families won’t have it. If you run a business, or work from home on company equipment, ask whoever looks after your IT.
- Send this page to your IT person.Ask them to confirm it’s fixed (fixed in version 2.23.6, 2.24.4 and 2.25.2 of geoserver), or not in use. CISA gave US government agencies until 5 Aug 2024 to fix it.
- If it can’t be fixed, take it offline.CISA’s advice when there’s no fix is to stop using the product, or take it off the internet, until there is one.
You can’t fix someone else’s server, but you can watch for what follows a break-in like this: a breach notice, a password reset you didn’t ask for, or a scam message that knows things it shouldn’t. HARD watches for those for you and your family.
Timeline
| Date | Event |
|---|---|
| The flaw is made public in the National Vulnerability Database, with a severity score of 9.8.[2] | |
| CISA adds it to its catalog of flaws known to be used in attacks.[1] | |
| CISA’s deadline for US government agencies to fix it.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at over 99%.[4] |
See also
Other OSGeo GeoServer flaws
- CVE-2025-58360: improper restriction of XML external entity reference ·
Other OSGeo flaws
- CVE-2022-24816, OSGeo JAI-EXT: geoServer JAI-EXT code injection ·
Similar flaws
- CVE-2025-24893, XWiki Platform: eval injection ·
- CVE-2023-7101, Spreadsheet::ParseExcel: remote code execution ·
- CVE-2021-22204, Perl Exiftool: remote code execution ·
Every OSGeo flaw on CISA’s list · Everything added in July 2024
References
- ^ Cybersecurity and Infrastructure Security Agency. “OSGeo GeoServer GeoTools Eval Injection Vulnerability”. Known Exploited Vulnerabilities Catalog, added 15 Jul 2024.
- ^ National Institute of Standards and Technology. “CVE-2024-36401 Detail”. National Vulnerability Database, published 1 Jul 2024.
- ^ OSGeo. Advisories and fixes: github.com, osgeo-org.atlassian.net.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.998, percentile 100.0, 31 Oct 2026.
- CVE Program. “CVE-2024-36401”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

