CVE-2026-48172

From Exploited flaws, HARD’s guide to the flaws being used in attacks · Checked
This article is about a flaw in LiteSpeed cPanel Plugin. For every flaw being used in attacks, see Exploited flaws.

CVE-2026-48172 is a security flaw in LiteSpeed cPanel Plugin. Someone who already has a foothold can use LiteSpeed cPanel Plugin to take full control of the machine. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 26 May 2026.[1]

LiteSpeed cPanel Plugin is business software or equipment. Most families won’t have it, but attackers break into it to get inside companies, and from there to what those companies hold about their customers, patients and staff. Fixed in version 2.4.7 and 5.3.1.0.

Description

CISA calls it a privilege escalation in LiteSpeed cPanel Plugin. In its words: “LiteSpeed cPanel Plugin contains privilege escalation vulnerability that is exposed via the user-end cPanel plugin, which can be abused by any cPanel user account to execute arbitrary scripts with root privileges.”[1]

The CVE record adds: “LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to root), as exploited in the wild in May 2026. Detection is best done via a command line of grep -rE "cpanel_jsonapi_func=redisAble" /var/cpanel/logs /usr/local/cpanel/logs/ 2>/dev/null in Bash. If you get no output, you have not been hit with exploitation of the vulnerability. If there is output, we recommend you examine the IP addresses in the list, determine if they are valid IP addresses, and if not, block them. To determine damage done, examine the system logs for use by the detected IP addresses. The issue is related to mishandling of Redis enable/disable features. The recommended minimum version is 2.4.7.”[2]

The underlying weakness is CWE-266, in MITRE’s list of common software weaknesses.

It scores 9.8 out of 10 on the Common Vulnerability Scoring System, which rates it critical, scored by NVD using CVSS 3.1.[2]

Affected versions

NVD’s record lists these fixed versions: in each line, everything before the version shown is affected.[2]

ProductFixed in
cPanel Plugin2.4.7
WHM Plugin5.3.1.0

Most families won’t have LiteSpeed cPanel Plugin; it’s for whoever looks after IT at work.

Exploitation

CISA added it to its catalog of known exploited vulnerabilities on 26 May 2026, 5 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 29 May 2026 to fix it.[1]

FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 18%. That’s in the top 3% of the flaws it scores.[4]

CISA assesses it as automatable: attackers can run it against many targets at once.

CISA doesn’t say who was attacked, or how.

Fix

LiteSpeed has published a fix or advice.[3] CISA’s required action: “Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.”[1]

  1. Check whether you use it.LiteSpeed cPanel Plugin is business software or equipment, so most families won’t have it. If you run a business, or work from home on company equipment, ask whoever looks after your IT.
  2. Send this page to your IT person.Ask them to confirm it’s fixed (fixed in version 2.4.7 and 5.3.1.0), or not in use. CISA gave US government agencies until 29 May 2026 to fix it.
  3. If it can’t be fixed, take it offline.CISA’s advice when there’s no fix is to stop using the product, or take it off the internet, until there is one.

You can’t fix someone else’s server, but you can watch for what follows a break-in like this: a breach notice, a password reset you didn’t ask for, or a scam message that knows things it shouldn’t. HARD watches for those for you and your family.

Timeline

DateEvent
The flaw is made public in the National Vulnerability Database, with a severity score of 9.8.[2]
CISA adds it to its catalog of flaws known to be used in attacks.[1]
CISA’s deadline for US government agencies to fix it.[1]
FIRST puts the odds of it being used in attacks in the next 30 days at 18%.[4]

See also

Other LiteSpeed cPanel Plugin flaws

References

  1. ^ Cybersecurity and Infrastructure Security Agency. “LiteSpeed cPanel Plugin Privilege Escalation Vulnerability”. Known Exploited Vulnerabilities Catalog, added 26 May 2026.
  2. ^ National Institute of Standards and Technology. “CVE-2026-48172 Detail”. National Vulnerability Database, published 21 May 2026.
  3. ^ LiteSpeed. Advisories and fixes: blog.litespeedtech.com, litespeedtech.com.
  4. ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.179, percentile 97.2, 31 Oct 2026.
  5. CVE Program. “CVE-2026-48172”. The official CVE record.

This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.