CVE-2026-54420
CVE-2026-54420 is a security flaw in LiteSpeed cPanel Plugin. Attackers are using a flaw in LiteSpeed cPanel Plugin. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 15 Jun 2026.[1]
LiteSpeed cPanel Plugin is business software or equipment. Most families won’t have it, but attackers break into it to get inside companies, and from there to what those companies hold about their customers, patients and staff. Fixed in version 2.4.8 of cPanel Plugin.
Description
CISA calls it a UNIX symbolic link (symlink) following in LiteSpeed cPanel Plugin. In its words: “LiteSpeed cPanel plugin contains a UNIX symbolic link (Symlink) following vulnerability that could allow a user with FTP or web shell access on a shared hosting server running CloudLinux/CageFS.”[1]
The CVE record adds: “LiteSpeed cPanel plugin before 2.4.8 (as distributed in LiteSpeed WHM PlugIn before 5.3.2.0) mishandles symlinks provided by a user with FTP or web shell access on a shared hosting server running CloudLinux/CageFS, as exploited in the wild in May 2026.”[2]
The underlying weakness is CWE-61, in MITRE’s list of common software weaknesses.
It scores 8.5 out of 10 on the Common Vulnerability Scoring System, which rates it high, scored by the organisation that published the CVE using CVSS 3.1.[2]
Affected versions
NVD’s record lists one fixed version: everything before it is affected.[2]
| Product | Fixed in |
|---|---|
| cPanel Plugin | 2.4.8 |
Most families won’t have LiteSpeed cPanel Plugin; it’s for whoever looks after IT at work.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 15 Jun 2026, within a day of it being made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 18 Jun 2026 to fix it.[1]
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 1%. That’s in the top 27% of the flaws it scores.[4]
CISA assesses it as not automatable: each attack takes some work.
CISA doesn’t say who was attacked, or how.
Fix
LiteSpeed has published a fix or advice.[3] CISA’s required action: “Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes).”[1]
- Check whether you use it.LiteSpeed cPanel Plugin is business software or equipment, so most families won’t have it. If you run a business, or work from home on company equipment, ask whoever looks after your IT.
- Send this page to your IT person.Ask them to confirm it’s fixed (fixed in version 2.4.8 of cPanel Plugin), or not in use. CISA gave US government agencies until 18 Jun 2026 to fix it.
- If it can’t be fixed, take it offline.CISA’s advice when there’s no fix is to stop using the product, or take it off the internet, until there is one.
You can’t fix someone else’s server, but you can watch for what follows a break-in like this: a breach notice, a password reset you didn’t ask for, or a scam message that knows things it shouldn’t. HARD watches for those for you and your family.
Timeline
| Date | Event |
|---|---|
| The flaw is made public in the National Vulnerability Database, with a severity score of 8.5.[2] | |
| CISA adds it to its catalog of flaws known to be used in attacks.[1] | |
| CISA’s deadline for US government agencies to fix it.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at 1%.[4] |
See also
Other LiteSpeed cPanel Plugin flaws
- CVE-2026-48172: privilege escalation ·
Added the same day
- CVE-2026-20262, Cisco Catalyst SD-WAN Manager: directory or path traversal ·
References
- ^ Cybersecurity and Infrastructure Security Agency. “LiteSpeed cPanel Plugin UNIX Symbolic Link (Symlink) Following Vulnerability”. Known Exploited Vulnerabilities Catalog, added 15 Jun 2026.
- ^ National Institute of Standards and Technology. “CVE-2026-54420 Detail”. National Vulnerability Database, published 14 Jun 2026.
- ^ LiteSpeed. Advisories and fixes: blog.litespeedtech.com.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.014, percentile 73.2, 31 Oct 2026.
- CVE Program. “CVE-2026-54420”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

