CVE-2021-21220
CVE-2021-21220 is a security flaw in Chrome and other Chromium browsers, the JavaScript engine inside Chrome, Edge, Brave, Opera and other Chromium browsers. Attackers are using a flaw in Chrome and other Chromium browsers. The US Cybersecurity and Infrastructure Security Agency (CISA) added it to its catalog of flaws known to be used in attacks on 3 Nov 2021.[1]
Chrome and other Chromium browsers is in things households have, such as phones, computers, browsers and everyday apps, so the fix matters at home as much as at work. Fixed in version 89.0.4389.128 of Chrome.
Description
CISA calls it an improper input validation in Google Chromium V8. In its words: “Google Chromium V8 Engine contains an improper input validation vulnerability that allows a remote attacker to potentially exploit heap corruption via a crafted HTML page. This vulnerability could affect multiple web browsers that utilize Chromium, including, but not limited to, Google Chrome, Microsoft Edge, and Opera.”[1]
The underlying weakness is improper input validation (CWE-20), heap buffer overflow (CWE-122), in MITRE’s list of common software weaknesses.[2]
It scores 8.8 out of 10 on the Common Vulnerability Scoring System, which rates it high, scored by NVD using CVSS 3.1.[2]
Affected versions
NVD’s record lists one fixed version: everything before it is affected.[2]
| Product | Fixed in |
|---|---|
| Chrome | 89.0.4389.128 |
Every device with Chrome and other Chromium browsers needs the update.
Exploitation
CISA added it to its catalog of known exploited vulnerabilities on 3 Nov 2021, 191 days after it was made public. CISA lists a flaw only when it has reliable evidence of it being exploited, and gave US federal agencies until 17 Nov 2021 to fix it.[1]
FIRST’s Exploit Prediction Scoring System, which estimates how likely a flaw is to be used in attacks in the next 30 days from what it sees across the internet, puts it at 70%. That’s in the top 1% of the flaws it scores.[4]
CISA assesses it as not automatable: each attack takes some work.
CISA doesn’t say who was attacked, or how.
Fix
Google has published a fix or advice.[3] CISA’s required action: “Apply updates per vendor instructions.”[1]
- Update Chrome and other Chromium browsers now.Chrome updates itself, but only finishes when you restart it: open the menu, choose Help, then About Google Chrome, and click Relaunch. Edge, Brave, Opera and Vivaldi need the same. Then turn on automatic updates, so the next fix arrives on its own.
- Check you’re on 89.0.4389.128 or later.Fixed in version 89.0.4389.128 of Chrome. Anything older is what attackers are going after.
- If there’s no update, stop using it.CISA’s advice when a flaw being used in attacks has no fix is to stop using the product until it does.
Timeline
| Date | Event |
|---|---|
| The flaw is made public in the National Vulnerability Database, with a severity score of 8.8.[2] | |
| CISA adds it to its catalog of flaws known to be used in attacks.[1] | |
| CISA’s deadline for US government agencies to fix it.[1] | |
| FIRST puts the odds of it being used in attacks in the next 30 days at 70%.[4] |
See also
Other Chrome and other Chromium browsers flaws
- CVE-2026-87491: out of bounds write ·
- CVE-2026-85046: type confusion ·
- CVE-2026-11645: out-of-bounds read and write ·
- CVE-2026-3910: improper restriction of operations within the bounds of a memory buffer ·
- CVE-2025-13223: type confusion ·
- CVE-2025-10585: type confusion ·
Other improper input validation flaws
- CVE-2026-93952, Arista VeloCloud Orchestrator: improper input validation ·
- CVE-2019-1068, Microsoft SQL Server: remote code execution ·
- CVE-2026-12569, PTC Windchill and FlexPLM: improper input validation ·
- CVE-2026-34910, Ubiquiti UniFi OS: improper input validation ·
- CVE-2026-6973, Ivanti Endpoint Manager Mobile (EPMM): improper input validation ·
Added the same day
- CVE-2021-42258, BQE BillQuick Web Suite: SQL injection ·
- CVE-2021-42013, Apache HTTP Server: path traversal ·
- CVE-2021-41773, Apache HTTP Server: path traversal ·
- CVE-2021-40539, Zoho ManageEngine: aDSelfService plus authentication bypass ·
- CVE-2021-40444, Microsoft MSHTML: remote code execution ·
Every Google flaw on CISA’s list · Everything added in November 2021
References
- ^ Cybersecurity and Infrastructure Security Agency. “Google Chromium V8 Improper Input Validation Vulnerability”. Known Exploited Vulnerabilities Catalog, added 3 Nov 2021.
- ^ National Institute of Standards and Technology. “CVE-2021-21220 Detail”. National Vulnerability Database, published 26 Apr 2021.
- ^ Google. Advisories and fixes: chromereleases.googleblog.com, lists.fedoraproject.org, lists.fedoraproject.org, lists.fedoraproject.org.
- ^ FIRST. “Exploit Prediction Scoring System”. EPSS 0.704, percentile 99.4, 31 Oct 2026.
- CVE Program. “CVE-2021-21220”. The official CVE record.
This article is built from CISA’s catalog (version 2026.10.30), NVD’s record and FIRST’s scores, kept in HARD’s database and checked every morning. The plain English is HARD’s.

